Goats Skinning Tutorial 

This is a skinning tutorial using Gimp 2. I have chosen to use this as it is free to download and available to all. Most of the tools described will be the same as using Photoshop.

To download Gimp 2 visit http://www.gimp.org/
I am not trying to make graphic artists here. The techniques will mostly be simple ways to create effective skins and will involve a lot of shortcuts, cheats and downright cheeky measures! It will be presented as a series of step by step measures. For people who know what they are doing some of rthis will seem very basic but its intended to let you create a skin with no previous knowledge of using image manipulation programmes.
So the car… we will be working with a Phoenix. The main reason for this is that it is a very simple vehicle to skin and most new players will acquire one at some point. Some of the cars have features that make them difficult to skin well. For example the Sunrise stretches across the bonnet (hood) and roof which can leave your skin looking distorted.

By the time we finish we will be looking to have created something like this…
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Top Tip – Gimp is a pretty good piece of software but like Photoshop it is very resource intensive and will sometimes become unstable and freeze. Save your skin often as you go along!
Using Showmodels

You probably want to look at the car as you go along and before you send it away for approval. At any point whilst making the skin you can look at your car by following these steps.

· make sure your car skin is saved using the same naming protocol as other skins of that type and saved in the correct vehicle folder in the darkwind programme file. Eg. The phoenix default skin is called cam69_1 and all the other phoenix skins are called cam69_1_1, cam 69_1_2 etc. call yours something like cam69_1_666 and save it in the phoenix folder

· Open the Darkwind client. In username type showmodels
· Leave the password field blank and click log in

· You will be taken to the darkwind lobby and it will say that you have entered an incorrect login

· Click on the picture of a car in the top left of the lobby screen

· You will have opened the showmodels box

· Select the correct vehicle type from the dropdown list (note not all vehicles are listed under their game name – eg. The apache is listed as Cherokee)

· Select your skin from the list of skins

· Set ‘damage texture strength’ to 0

· Set ‘accessories scale’  to 0

· Check the ‘flip wheels’ box

· Click OK

You will now be able to view your model in 3D – rotate it and zoom in on the skin.

Step 1

The first thing to do is to find the template for our skin. The skins of the vehicles are simple JPEG files with the various body panels laid out on a 512 x 512 pixel square. In order to make your skin fit the 3D model it is best to work from an existing template drawing over the existing skin. To find your template you need to open an existing skin. These are found in the Darkwind Programme File under shapes, vehicles, vehicle name. Normally you will need to go to:
C:\Program Files\Darkwind\darkwind\data\shapes\vehicles\phoenix
Open the vehicle skin cam69_1 using Gimp 2

You should have this skin open
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as you can see only one side of the vehicle is shown. This is because on the model the skin is simply mirrored. 

Top Tip – You cant use letters or numbers on parts of a car that are mirrored on the model. Words and numbers will appear backwards on one side of the car. Restrict lettering and numbering to those parts of the car that are not mirrored (in the case of the phoenix the back). The only exception to this would be letters and numbers that have symmetry along the vertical axis (eg. 8, A, I, M, X). but note that if you write AIM 8 on the door of the phoenix it will appear as 8 MIA on the other side! There is a rare skin phoenix in the wild with an 8 pool ball on the door… very simple and effective.
Save the skin under a new name as a JPEG file.

· Go to the File menu
· Select  ‘Save As’
· Change the name of the file to yourskinname.jpg

· Click ‘Save’

· On the next menu you will see a slide bar marked ‘Quality’ this determines the level of compression the file uses. For now move it to 100 (for maximum quality)

· Click ‘Save’
Step 2
We need an urban camouflage pattern to work from. A quick Google image search turns up this image which is an interesting digital camouflage take on traditional urban camo. When choosing an image to use you need to find an image that is large enough. Ideally it should have pixel dimensions larger than your template. Save the image onto your computer.
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Top Tip – a degree of plagiarism is inevitable if you want to create a decent skin simply. But there is nothing stopping you using the paint tools (paintbrush, spraycan and pencil) to create your own camo pattern. If you are doing this open a new blank canvas sized 512 x 512 pixels and let your imagination run riot!
Step 3

Back on our car template we are going to avoid having to put too much work into shading our skin to match the contours of the original vehicle by … to put it bluntly… cheating (
First we are going to turn our vehicle grey

· Open the ‘Colours’ menu

· Choose ‘Desaturate’

· Check ‘Luminosity’

· Click ‘OK’

Your skin should now look like this
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We are going to use the lasso tool [image: image5.png]


 to select the door of our vehicle.
· Click on the lasso tool icon

· Left click on the bottom left corner of the door

· Now click further along the outline of the door – your two clicks will now be connected by a line

· Click your way round the outline of the door.. basically you are going to be making the shape of the door out of a series of short straight lines. The shorter the lines the better you can match the curves.

· If you place one of your clicks wrongly you can move it by left clicking within the little circle and dragging it to a new position

· Once you have gone round the door outline your final left click will be within the circle of your first. The lines and circles will disappear and you will have a neat flickering outline around your selection

· You should have selected the shape shown in red below
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· Open the ‘Edit’ menu

· Select ‘Copy’

Step 4
You are now going to cut the camouflage pattern to fit the door… but we are going to retain some of the shading from the original skin.

· Open your camouflage pattern in gimp

· Select the pencil tool from the toolbox [image: image7.png]



· The bottom half of your toolbox now has the settings for the pencil. We are going to reduce the opacity. Change the slider to 33%
· In the pencil settings you will see a drop down menu of brush types. If you open it you will see that the top left option is now the door panel you copied

· Select this brush type and click once on your camouflage pattern
You will now have faintly drawn the door panel over the camouflage like this (its faint.. deliberately so):
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Top Tip 3 – Sometimes it helps to get up close. Use the Zoom option in the View menu to help. 
· get your lasso tool out again
· use it to select the door panel shape on the camouflage as in step 3

· Copy
· Go back to the car skin JPEG
· Paste

If the door panel is still selected on the car skin the paste will line up with this. If not use the move tool [image: image9.jpg]


 to drag and drop the pasted section into position. If you did it right it should look like this:
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Step 5
Repeat steps 3 and 4 for the remaining vehicle panels. Don’t worry about the windows. We will come to them later. When you have finished your skin should look like:
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Step 6
Its nice... but its very grey…. You can have it in any colour you want!

· make sure you have nothing selected

· open the colour menu

· select colourise and play with the hue and saturation sliders

it’s a desert out there so I have gone for…
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Step 7
Its time to add some definition and lines. Vehicles work well in Darkwind with high contrast. They are very small on screen so you want lines around doors and other details to show up clearly. To darken lines we are going to use the paintbrush tool [image: image13.png]



· select the paintbrush tool

· click on the colour box in the tool bar and choose a dark shade that matches your colour scheme. I have taken a very dark brown.
· In the paintbrush settings choose the smallest size of circle fuzzy brush

· Set the opacity at 30%

· Trace the lines of the car… hold shift to drag lines or draw freehand… go over areas repeatedly to build up shadow

Mine now looks like this
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Step 8

Its still all a bit flat time for some detail…

Windows.. I have found a wire mesh I like in Google images. Its from a speaker b ut it will make nice windows:
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· I use the same lasso method to cut out the shapes and add windows to the car. This time however I don’t want the old skin to show at all. I select the window shape, copy, go to my mesh image and use the pencil to draw the shape as before..

· I now use the lasso tool to go round the window shape BUT before I do the final click to close the selection I open the edit menu and select ‘undo pencil’

· Hey presto. I can now close the selection an cut out only the mesh for the window.
After pasting in the windows my car looks like this:
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Step 9 - All the little details.

Google images is your best friend…. I could spend ages drawing a door handle… or I could fins a photograph of a car with a nice door handle and cut it out using my trusty lasso.

Your other great friend here is scale. When you have copied and pasted your door handle or headlight it will be much to big.
· with the item you have pasted still selected go to the ‘Layer’ menu

· Select ‘scale layer’

· You can now adjust the size of the item by increasing or decreasing the number of pixels

Some cutting and pasting and scaling of bits and pieces – some additional shading to deepen shadows around windows and some dirty commie stars cut out from a picture of a decal sheet found on google images and we end up with…
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Step 10 – Saving and submitting
Its time to save your file for the final time and submit it to Sam for approval.
The main skin file needs to be saved as a JPEG of no more than 200kb. Lets do this now.

· go to the ‘File’ menu

· click ‘save as’

· in the dialogue box that now appears look towards the bottom where it says ‘Select File Type by Extension’ and click the ‘+’ sign beside it

· scroll down the list of fie types and select JPEG

· click ‘save’

you will now have a dialogue box open with a slider for ‘quality’ if you are lucky under this it will be displaying the current file size if you save at that quality (it mostly says unknown!). With most skins saving at quality 98% will be less than 200kb but you may have to save, check how big the file is on disk and then resave if its still too large.
· shift the slider to 98

· click ‘save’

Your file is now saved ready for submission. But we also need to create and save a swatch. This is a 20 pixel by 20 pixel GIF file that you will see when you click ‘repaint’ on the website to paint your car. It needs to be something you will recognise. I normally choose a recognisable patch of the skin although you can use any picture you want so long as you remember which skin it represents.

· click ‘file’

· click ‘new’

· in the image size dialogue box change the width and height dimensions to 20 pixels

· click ‘OK’

now go back to your skin and use your rectangle select tool [image: image18.png]


 to select a patch of the skin that is 20/20 pixels.

· go to the ‘edit’ menu

· click ‘copy’

· swap back to your new image

· click ‘edit’

· click ‘paste’

· go to the ‘File’ menu

· click ‘save as’

· give your image a name in the ‘name’ box

· in the dialogue box that now appears look towards the bottom where it says ‘Select File Type by Extension’ and click the ‘+’ sign beside it

· scroll down the list of fie types and select ‘GIF image’

· click ‘save’

· when the ‘export file’ dialogue box appears click ‘export’

· click ‘save’

To submit the skin and swatch go to the vehicles page on your gangs web area. On the right hand side under your decals you will see the ‘add custom skin’ button. Click this, choose the correct chassis from the drop down list, click browse and upload your JPEG. A new browse button wioll appear to add your GIF.

The skin will now need to be approved. Sam normally does this pretty quickly but have a bit of patience. He is not Microsoft (thankfully!)

Top Tip – Once your skin is approved it will be available when you repaint a car of that chassis type. You have three free skin slots and more can be purchased. Note that if you paint a car and sell it on you will be unable to delete that skin until the car it is on is repainted or destroyed!

